Login Form

Registered users

Registered Users 1300
Registered Today 0

Visitors

Today38
Yesterday169
Week362
Month38
All36836

Currently are 7 guests and no members online

Breaking news

  • March 2 2015, 10:30 ZULU vACMI version 2.6.6 for P3D 2.5

    March 2 2015, 10:30 ZULU, see Service packs

    1. APPLIES TO P3D 2.5 ONLY
    2. This incremental version 2.6.6 is released as a service pack and must be applied to an already installed Vacmi version 2.6.5 for P3D 2.x
    3. It fixes a bug related to P3D 2.5, vACMI failed to CTD.
     
  • January 29 2015, 07:30 ZULU vACMI version 1.6.8 for FSX/P3D14

    January 29 2015, 07:30 ZULU, see Service packs

    1. This incremental version needs to be applied to vACMI version 1.6.7, it won't install on previous versions.
    2. It fixes a nasty and subtle bug able to clog the P3D server into multiplayer environment.
    3. Users that have problems with proper vACMI activation and connection in P3D v. 1.4 should try to donwload and substitute the legacy dll we provide into service packs.
     
  • Sept 29, 2014 ** NOTAMS TO OUR CUSTOMER **
    1. FROM OCTOBER 1ST 2014 WE DO NOT GIVE SUPPORT VIA E-MAIL ANY LONGER
    2. ALL REGISTERED  SHOULD USE THE HELP DESK
    3. NON  REGISTERED USERS MAY USE CONTAC@US
    4. ANY E-MAIL MESSAGE REQUESTING SOFTWARE SUPPORT WILL BE TRASHED
    5. The SSW support forum should be used to send questions, suggestions and complaints about the use of our models and report bugs in the general interest if any.